KB0058 - PowerShell Universal Browser Times Out Before Session Timeout When Using OIDC
Affected Versions
- All Support Versions
Problem
Setting the session timeout in appsettings.json does not have an affect on how soon the user is logged out from their session.
Root Cause
When using OpenID Connect, the -UseTokenLifetime parameter causes the ticket to time out based on the lifetime of the token provided by the authentication provider rather than the configured cookie session timeout.
Workaround
Remove the -UseTokenLifetime parameter from New-PSUAuthenticationMethod or set it to false in appsettings.json to use the session timeout rather than the token timeout.
Related Articles
PowerShell Universal Service crashes on startup after an upgrade to 1.4.6
Version: PowerShell Universal 1.4.6 Issue The PowerShell Universal service will crash with the following error in Event Viewer. Application: Universal.Server.exe CoreCLR Version: 4.700.19.56402 .NET Core Version: 3.1.0 Description: The process was ...
KB0074 - Connecting to PSU API w/Windows Auth
Scope This article applies only to PSU environments where Windows Authentication[1] is enabled and known to be working[2]. Problem You are not able to interact with the PSU instance using the Invoke-WebRequest PowerShell cmdlet even though logging in ...
KB0011 - Are licenses different between Production, QA and Test/Development servers?
Update January 24th, 2023 Adam recently summarized the Developer's license per below: The only real limitation on the developer license is that it cannot be accessed remotely. The server is only available on loopback when using the dev license. If ...
KB0066 - Get-WMIObject cmdlet not working
Scope This article applies to any scenario where the Get-WMIObject cmdlet is expected to be available and functioning within a PowerShell Universal instance. Effectively, this article will only apply to instances that run under the Windows operating ...
KB0034 - How to collect logs
Purpose The purpose of this article is to provide clear ordered steps for users of PowerShell Universal and to submit them to Ironman Software (typically for a support case). Background Having logs from PowerShell Universal is typically needed to ...