KB0047 - CPU Health check failed: Access to the registry key 'Global' is denied.
Scope
This article applies to PowerShell Universal
(Kestrel - MSI installer)
version 4.0.0 and above
[1]
on Windows Server.
Problem
There is a failed CPU health check related to a 'Global' registry key.
(above figure shows the PowerShell Universal health checks log with a failure due to lack of access to the registry key 'Global')
Root cause
The service account or (application identity pool) does not have access to the Performance Monitors.
[2]
Solution
1. Add the service account or application pool identity to the Performance Monitors
[3]
group.
2. Restart the PowerShell Universal service
3. Confirm from the health check logs that the CPU check is either passing or failing for a different reason
(above figure shows the PowerShell Universal health checks log is no longer failing due to lack of access to the registry key 'Global')
References