KB0022 - Unable to login after upgrading to PowerShell Universal 3.7.1

KB0022 - Unable to login after upgrading to PowerShell Universal 3.7.1

Affected Versions

- PowerShell Universal 3.7.0
- PowerShell Universal 3.7.1

Issue

A user attempts to login with the default admin account and cannot access the system. 

Solution

- Upgrade to PowerShell Universal 3.7.2
Remove the admin account from the database (LiteDB or SQL) in the identities table
- Downgrade to 3.6.4

Root Cause

PowerShell Universal 3.7 added a local account feature to allow for users to create accounts directly within PowerShell Universal. The default admin account is considered a local account. If the system had previously been accessed by the admin account, and no other authentication or role configuration was completed and no license was installed, the user would not be able to login because the enterprise login features were either disabled due to licensing or unconfigured.